GRADLE Warning message during Building

During building my App for Andoird I got the following warning, any idea to get ride of them ? (however the application build fine)

[ERROR] [GRADLE] Warning: This version only understands SDK XML versions up to 2 but an SDK XML file of version 3 was encountered. This can happen if you use versions of Android Studio and the command-line tools that were released at different times.
[ERROR] [GRADLE] Warning: �l�ment inattendu (URI : "", local : "base-extension"). Les �l�ments attendus sont <{}codename>,<{}layoutlib>,<{}api-level>

looks like its either the gradle version or the emulator version:

Did you see anything wrong below ?

Operating System
  Name                        = Microsoft Windows 10 Famille
  Version                     = 10.0.19044
  Architecture                = 64bit
  # CPUs                      = 4
  Memory                      = 7.9GB

Node.js
  Node.js Version             = 14.9.0
  npm Version                 = 6.14.8

Titanium CLI
  CLI Version                 = 5.4.1
  node-appc Version           = 1.1.4

Titanium SDKs
  10.1.1.GA
    Version                   = 10.1.1
    Install Location          = C:\ProgramData\Titanium\mobilesdk\win32\10.1.1.GA
    Platforms                 = android
    git Hash                  = 2448cfa671
    git Timestamp             = 11/18/2021 17:12
    node-appc Version         = 1.1.2

Intel® Hardware Accelerated Execution Manager (HAXM)
  Installed                   = yes
  Memory Limit                = 0 BYTES

Java Development Kit
  Version                     = 16.0.2_7-67
  Java Home                   = C:\Program Files\Java\jdk-16.0.2

Genymotion
  Path                        = not found
  Genymotion Executable       = not found
  Genymotion Player           = not found
  Home                        = not found

VirtualBox
  Executable                  = not found
  Version                     = unknown

Android SDK
  Android Executable          = not found
  ADB Executable              = C:\Adroid\SDK\platform-tools\adb.exe
  SDK Path                    = C:\Adroid\SDK

Android NDK
  NDK Path                    = C:\Adroid\SDK\ndk\21.4.7075529
  NDK Version                 = 21.4.7075529

Android Platforms
  1) android-31
    Name                      = Android 12
    API Level                 = 31
    Revision                  = 1
    Skins                     = HVGA, QVGA, WQVGA400, WQVGA432, WSVGA, WVGA800, WVGA854, WXGA720, WXGA800, WXGA800-7in
    ABIs                      = x86_64
    Path                      = C:\Adroid\SDK\platforms\android-31

Android Add-Ons
  None

Android Emulators
  5.4  FWVGA API 31
    ID                        = 5.4_FWVGA_API_31
    SDK Version               = not installed
    ABI                       = x86_64
    Skin                      = 480x854
    Path                      = C:\Users\dzzd-romain\.android\avd\5.4_FWVGA_API_31.avd
    SD Card                   = C:\Users\dzzd-romain\.android\avd\5.4_FWVGA_API_31.avd\sdcard.img
    Google APIs               = yes

Genymotion Emulators
  None

Connected Android Devices
  None

Issues
  No issues detected! Your development environment should be working perfectly!

that looks fine. Here is another info about the issue:

As mentioned in the message, this is happening because you have some packages that were installed that are using the v3 format for package.xml, but then reading it with a tool that only knows about v2. Probably you installed some components using the canary studio. If you want to you could uninstall the problem components and reinstall using sdkmanager or the stable studio. Or you could just ignore the message for now, until the new cmdline-tools is out, which should happen alongside the next studio stable release. – Google Issue Tracker

I’ve never seen that error before, I always let the ti cli install gradle and I use Android Studio to install the rest.

Ok the problem was solved by installing Gradle (from here Gradle | Installation)

I suppose it was using the default Internal Android Studio Gradle as I never installed it.

Errors are gone now, but I still get a last warning message wich I suppose comme from one of my file :

[INFO]  Building app
[ERROR] [GRADLE] Warning: �l�ment inattendu (URI : "", local : "base-extension"). Les �l�ments attendus sont <{}codename>,<{}layoutlib>,<{}api-level>

the ti cli will automatically install gradle if it doesn’t find any. 7.0.1 should be the current version.

I must have made installation of the different compoents (Androis Studio, node, titanium,…) in the wrong order.

I got the same problem when I try my first build on my new computer. Finally found where it come from and how to remove it.

The reason comme from a Gradle’s updated.

This require reinstallation of SDK Plateforms & delete/rebuild of application.

To remove the warning :

  • Uninstalled SDK Plateforms>Android SDK Platform XX
  • Delete all files built by the application (build folder, gradle files, …)
  • re-Install SDK Plateforms>Android SDK Platform XX
  • Build application